请选择 进入手机版 | 继续访问电脑版

1

阿木币

0

精华

0 小时

在线时间

应届白菜

Rank: 1

发表于 2022-11-17 18:50:14 88 浏览 2 回复

[飞控嵌入式] px4子模块问题


teslian@ubuntu:~$ git clone https://github.com/PX4/PX4-Autopilot.git
正克隆到 'PX4-Autopilot'...
remote: Enumerating objects: 424195, done.
remote: Counting objects: 100% (677/677), done.
remote: Compressing objects: 100% (384/384), done.
remote: Total 424195 (delta 417), reused 433 (delta 290), pack-reused 423518
接收对象中: 100% (424195/424195), 197.46 MiB | 2.98 MiB/s, 完成.
处理 delta 中: 100% (313899/313899), 完成.
teslian@ubuntu:~$ ls
examples.desktop  ubuntu_sim_common_deps.sh  模板  文档  桌面
PX4-Autopilot     ubuntu_sim_ros_melodic.sh  视频  下载
ubuntu.sh         公共的                     图片  音乐
teslian@ubuntu:~$ cd ~/PX4_Autopilot
bash: cd: /home/teslian/PX4_Autopilot: 没有那个文件或目录
teslian@ubuntu:~$ cd PX4-Autopilot
teslian@ubuntu:~/PX4-Autopilot$ gedit .gitmodules
teslian@ubuntu:~/PX4-Autopilot$ git submodule update --init
fatal: 在 .gitmodules 中未找到子模组 'Tools/simulation/flightgear/flightgear_bridge' 的 url
teslian@ubuntu:~/PX4-Autopilot$


我知道答案 回答被采纳将会获得3 阿木币 已有2人回答

扫一扫浏览分享
回复

使用道具 举报

209

阿木币

1

精华

51 小时

在线时间

老司机

Rank: 2

发表于 2022-11-24 10:47:40
这种一般都是网络问题 科学上网都能解决
回复 点赞

使用道具 举报

1

阿木币

0

精华

17 小时

在线时间

应届白菜

Rank: 1

发表于 3 天前
子模块更新这一步出错的原因一般都是网络引起的,科学上网能解决,或者直接从网上找一下别人下载好的完成的px4固件直接编译就可以使用
回复 点赞

使用道具 举报

返回列表
您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

快速回复 返回顶部 返回列表